Monday, April 15, 2019

Vulnerabilities in Dell SupportAssist Software

 Vulnerabilities were recently discovered, by a 17 year old security researcher, in Dell support software, that is included on Dell desktop and laptop computers, that could allow an attacker to compromise, and take over, the computer.



If you have a Dell computer, you should either remove or update the Dell SupportAssist software to the latest version (3.2.0.90 or newer).


The latest verison of the Dell SupportAssist software can be downloaded from Dell at this website


https://www.dell.com/support/contents/us/en/04/article/product-support/self-support-knowledgebase/software-and-downloads/supportassist


Dell has published a security advisory, about this issue, which can be found here…


https://www.dell.com/support/article/us/en/04/sln316857/dsa-2019-051-dell-supportassist-client-multiple-vulnerabilities?lang=en


If you need assistance to remove or update the Dell SupportAssist software, on your Dell computer, you can contact Dell Support, if your computer is still under warranty. Otherwise, you can find a list of local computer shops, that can assist you, here


https://www.ericscomputerclinic.com/local-computer-shops.html


It may also be a good time to remind customers to Avoid Tech Support Phone Scams. If you receive a phone call from someone claiming to represent Dell, Microsoft, or any other similar company, you should be suspicious. Dell has published Five Tips to Help You Avoid Tech Support Phone Scams


https://blog.dell.com/en-us/five-tips-help-you-avoid-tech-support-phone-scams/

Happy Easter

  Dear Lord, may I realize afresh today what Your death and resurrection mean for me. Forgiveness, freedom, and the ability to walk with You...